summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:53:37 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:51 -0700
commitbaafeb566a0feb3b5274d2c5aca5875f8a74974e (patch)
treefbf9cb0ca47722bdbe0e24dabbbeb4388e303f5f /dev-python/pytest-cache
parentdev-python/qdarkstyle: add py3_9 (diff)
downloadgentoo-baafeb566a0feb3b5274d2c5aca5875f8a74974e.tar.gz
gentoo-baafeb566a0feb3b5274d2c5aca5875f8a74974e.tar.bz2
gentoo-baafeb566a0feb3b5274d2c5aca5875f8a74974e.zip
dev-python/pytest-cache: add py3_8,9 rem py2,3_6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cache')
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild
new file mode 100644
index 000000000000..32f786371d38
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-cache/
+ https://bitbucket.org/hpk42/pytest-cache/
+ https://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}