summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 09:57:45 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit5a21620142ed5b3aca9b8d1ae72953495da24d27 (patch)
treec4d06967de66f791b7ca77eb76355a37137bb5f4 /dev-python/pytest-catchlog
parentdev-python/pytest-capturelog: Add tests (diff)
downloadgentoo-5a21620142ed5b3aca9b8d1ae72953495da24d27.tar.gz
gentoo-5a21620142ed5b3aca9b8d1ae72953495da24d27.tar.bz2
gentoo-5a21620142ed5b3aca9b8d1ae72953495da24d27.zip
dev-python/pytest-catchlog: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-catchlog')
-rw-r--r--dev-python/pytest-catchlog/Manifest1
-rw-r--r--dev-python/pytest-catchlog/pytest-catchlog-1.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-catchlog/Manifest b/dev-python/pytest-catchlog/Manifest
index 77ac4ef5f5cc..526a4a7c8094 100644
--- a/dev-python/pytest-catchlog/Manifest
+++ b/dev-python/pytest-catchlog/Manifest
@@ -1 +1,2 @@
DIST pytest-catchlog-1.1.tar.gz 6540 SHA256 7ad18d77b93d70c4ea30ed4593b164be104efc50a9112a5733304a71f2cb1119 SHA512 7a272874f9fb4231a7b3a42742b752f0f9750fb861abfed0411bf8edae5ab3e67a0a33fe166e485d530a1ecf1834d131d3affcfc43a735fc5d28018ba155129a WHIRLPOOL cf04096c01176fc077c45ca26b5002e10cdc145e3d3ea83cc7594eb2cbaa3a7636ba661253b1a8e47e316407e672c5ee424df10d8026bc6adb2c04499d386d3f
+DIST pytest-catchlog-1.2.0.zip 13620 SHA256 e419a4efc706c948fbac2c5e8a35bb6f16edb3bb0643b86ba28b6bc69e792d32 SHA512 9ab42f5bcec14ab452c1466a7a148270e25c2bda722739101a48802ec61b7cef5099605330c29e46b68d2e7c7452d93b6ca1402e80d083f8e2deec02d38e743a WHIRLPOOL 77a8c24e11ca4da9e42b212b7b022c27f2166a8e559a94f0744dc81aaafd7d3ccfd20b2413cf061bc1c2ea85e540c8a6c7e77a7aff0d1d68587c80ed97e94568
diff --git a/dev-python/pytest-catchlog/pytest-catchlog-1.2.0.ebuild b/dev-python/pytest-catchlog/pytest-catchlog-1.2.0.ebuild
new file mode 100644
index 000000000000..776e554d069d
--- /dev/null
+++ b/dev-python/pytest-catchlog/pytest-catchlog-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to catch log messages, fork of pytest-capturelog"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-catchlog https://github.com/eisensheng/pytest-catchlog"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/py-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.7.1[${PYTHON_USEDEP}]
+ )"
+
+# Not included
+# https://github.com/eisensheng/pytest-catchlog/issues/13
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=${PN/-/_} py.test -v -v test_pytest_catchlog.py || die
+}