summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 08:54:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:41:11 +0100
commit3566a5ace4de0bb5700a3ab11a436430474f25ed (patch)
treee1273e219f15be48cf106b883f166ae2344e0b4b /dev-python/pytest-check
parentdev-python/Faker: Bump to 15.3.3 (diff)
downloadgentoo-3566a5ace4de0bb5700a3ab11a436430474f25ed.tar.gz
gentoo-3566a5ace4de0bb5700a3ab11a436430474f25ed.tar.bz2
gentoo-3566a5ace4de0bb5700a3ab11a436430474f25ed.zip
dev-python/pytest-check: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/metadata.xml2
-rw-r--r--dev-python/pytest-check/pytest-check-1.1.3.ebuild27
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index 8680d5c35ea3..51ee33335cf9 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1,2 +1,3 @@
DIST pytest-check-1.0.10.tar.gz 15603 BLAKE2B e51dbb2806bdac73e202b14668c76675979113f661eb339a1a3cff07069d3d4709869d67ea2cb6384483ebde8b68288026df9b7492b17ea67c79ee95e6865809 SHA512 dc3a80b20637eab8adda085ca8172bc3bde75bd47566972a07cf226bb38771933a531d99e139d7c220cc149715fd7d98ab964f72e0b520e8dd3df7633a6e5a90
DIST pytest-check-1.1.2.tar.gz 19090 BLAKE2B 25d483c29f7a357b26d6153582e9ca0a4b6f6c5c97baf9e8a12403de6993f44fa4d4eea370f1c800036062abffb68cbcf826c210f7eb32ef4fefcbfde031674f SHA512 64e74e399cecc6733aeca7ca88dedb110029394548c0b3e27d0f35e034887fbb9a3d6a2da7b30e52a5fa68f535e15373173ffaf391afa02783009e5edb6637d3
+DIST pytest-check-1.1.3.tar.gz 19461 BLAKE2B e6ba332f3326992842a50323c6062283c3227d15526cc0f33f51a90455e7a30f0f53e96907896eeecce4a13b8e6fafcc8112eecfc844310200e107e92150d3d0 SHA512 af89cc90de9a72600d79947d2f771fe878dc55add754dae447afe8c0df47745842c35867ebc104825189c119858a7ddde992e91b48dab4f9e74fd71e7b55f51e
diff --git a/dev-python/pytest-check/metadata.xml b/dev-python/pytest-check/metadata.xml
index 5db435fa7f11..5d7827d9d2b4 100644
--- a/dev-python/pytest-check/metadata.xml
+++ b/dev-python/pytest-check/metadata.xml
@@ -12,6 +12,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="github">okken/pytest-check</remote-id>
- <remote-id type="pypi">pytest_check</remote-id>
+ <remote-id type="pypi">pytest-check</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pytest-check/pytest-check-1.1.3.ebuild b/dev-python/pytest-check/pytest-check-1.1.3.ebuild
new file mode 100644
index 000000000000..9a459557d506
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest