summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-23 20:18:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-23 20:21:57 +0300
commitda0dcf14c8cd9e3fc553c790b936cb7f1b5ec854 (patch)
treead5b8660a3f4ec6f8fbfccfcb85be99f865108ad /dev-python/pytest-check
parentx11-misc/mygestures: fix possible race condition (diff)
downloadgentoo-da0dcf14c8cd9e3fc553c790b936cb7f1b5ec854.tar.gz
gentoo-da0dcf14c8cd9e3fc553c790b936cb7f1b5ec854.tar.bz2
gentoo-da0dcf14c8cd9e3fc553c790b936cb7f1b5ec854.zip
dev-python/pytest-check: new NIH test dep for dev-python/sphobjinv
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/metadata.xml13
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.4.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
new file mode 100644
index 000000000000..7cb85a73456f
--- /dev/null
+++ b/dev-python/pytest-check/Manifest
@@ -0,0 +1 @@
+DIST pytest-check-1.0.4.gh.tar.gz 7738 BLAKE2B 179575dfd4f9e50715fd5a664039fe882b0e14c9369afb6f7aca65e9ab276147b2a0b7fe580d2a249721152d891c12cedfa06ae7e26027c6b7d3b34da17d4a53 SHA512 ca71295fc5a831df295c8ce40c6a57cde9a1b98ca25354a3954fc44c9094096ea0c9c6a49139659d4c9aa4e3d3d81d80893edb657bfd3f4d988c75864e843447
diff --git a/dev-python/pytest-check/metadata.xml b/dev-python/pytest-check/metadata.xml
new file mode 100644
index 000000000000..af6127a0bf2a
--- /dev/null
+++ b/dev-python/pytest-check/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">okken/pytest-check</remote-id>
+ <remote-id type="pypi">pytest_check</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-check/pytest-check-1.0.4.ebuild b/dev-python/pytest-check/pytest-check-1.0.4.ebuild
new file mode 100644
index 000000000000..08ebac53b79f
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="https://github.com/okken/pytest-check https://pypi.org/project/pytest_check/"
+SRC_URI="
+ https://github.com/okken/pytest-check/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pytest-6[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/flit_core[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+ mv src/pytest_check pytest_check
+}