summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-12 09:46:58 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-12 09:46:58 -0400
commit4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580 (patch)
treec036039ba47bbe29789949fffa1e90f4d38a5d14 /dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
parentdev-python/pytest-cov: bump to 2.6.1 (diff)
downloadgentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.tar.gz
gentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.tar.bz2
gentoo-4bdb9c403ad1461ba56dce08a9f2c1f1a3c2a580.zip
dev-python/pytest-cov: remove old
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild b/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
deleted file mode 100644
index 6683bf30f929..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.5.1-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}