summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 19:32:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 19:48:26 +0100
commit84c5be23e827cd487c484f647308f1d521e86382 (patch)
tree0820a3e7f5068aa6f5250c7edccba1c5ecb9190b /dev-python/pytest-cov
parentdev-python/pytest-cov: Stabilize 2.8.1 ALLARCHES (diff)
downloadgentoo-84c5be23e827cd487c484f647308f1d521e86382.tar.gz
gentoo-84c5be23e827cd487c484f647308f1d521e86382.tar.bz2
gentoo-84c5be23e827cd487c484f647308f1d521e86382.zip
dev-python/pytest-cov: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch16
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.6.1-disable-broken-tests.patch22
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.3.1.ebuild60
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.6.1.ebuild58
5 files changed, 0 insertions, 158 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 80209ad865e4..89a5464f923b 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,3 +1 @@
-DIST pytest-cov-2.3.1.tar.gz 35378 BLAKE2B 758846db0b06ef9534823d3458ad6211b0cfc14b551a6e1737573a5c1c5bb59c23b26d3448ff8a67d65a4293ce75dd8c79d4916d3d9a7db5021db6b907152230 SHA512 79770beb53fbb43b5d68311c2efd0accbfd890ab6dad299da8c1c0b3d26b54d984807313b1507900cda7004bfb50fedc0bd4341cfcfce47849a4f24fc8184f11
-DIST pytest-cov-2.6.1.tar.gz 35307 BLAKE2B 11974ff70ed5609d7db3c4c35f5b528b0ec36b48cfaf06974a090127706e0964841347592ac3f1e086f46800857ee10c05404045b6a4b467ffa278c2ee1e1957 SHA512 2dfd16e013d8bfbe5d14990f419291b651dd11560328a7e59b5449016d51b17f84d4ee3866fda866c3530389d206b1c4c67c84b23f097281c3963ffd19ea8caa
DIST pytest-cov-2.8.1.tar.gz 47661 BLAKE2B 590fd50b69d01a71b20982d8cdbed0698ebe24c290d791bb44c96aa1aaaf77cf1f379d565eb775864c6945facf6d271115236cb44b95e4a4c9bb7cc6fd591acf SHA512 769a17c2095dbe990df148a0105c9e3dc88ac2265ac77ac31448dab6abf6d8cc0d54f5c6ff01fd708bd38700bfea93f57d3bb702bd9bb0a708257d094b2376ec
diff --git a/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch b/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch
deleted file mode 100644
index a555ca53fc91..000000000000
--- a/dev-python/pytest-cov/files/fix-for-deprecation-warnings.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index 6cbf341..614e53c 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -337,7 +337,10 @@ def test_central_nonspecific(testdir):
- ])
-
- # multi-module coverage report
-- assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-4:])
-+ # Fix test failure due to pytest deprecation warnings being
-+ # added to the expected output. Look in entire output lines instead.
-+ # assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-4:])
-+ assert any(line.startswith('TOTAL ') for line in result.stdout.lines[-10:])
-
- assert result.ret == 0
-
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.6.1-disable-broken-tests.patch b/dev-python/pytest-cov/files/pytest-cov-2.6.1-disable-broken-tests.patch
deleted file mode 100644
index 1d8e36b451b2..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.6.1-disable-broken-tests.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index 2896ac9..5f753e8 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -699,7 +699,7 @@ parallel = true
- assert result.ret == 0
-
-
--def test_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
-+def xtest_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
- stuff = testdir.mkdir('stuff')
- parent_script = stuff.join('parent_script.py')
- parent_script.write(SCRIPT_PARENT_CHANGE_CWD_IMPORT_CHILD)
-@@ -829,7 +829,7 @@ def test_invalid_coverage_source(testdir):
-
-
- @pytest.mark.skipif("'dev' in pytest.__version__")
--def test_dist_missing_data(testdir):
-+def xtest_dist_missing_data(testdir):
- venv_path = os.path.join(str(testdir.tmpdir), 'venv')
- virtualenv.create_environment(venv_path)
- if sys.platform == 'win32':
diff --git a/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
deleted file mode 100644
index f3edac318137..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.3.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
- >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- || (
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- )
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/fix-for-deprecation-warnings.patch"
-)
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- PYTEST_PLUGINS=${PN/-/_} \
- py.test -v -v -x || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest-cov/pytest-cov-2.6.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.6.1.ebuild
deleted file mode 100644
index 2afc94aafe0d..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- dev-python/process-tests[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Bug 597708
- "${FILESDIR}/${PN}-2.6.1-disable-broken-tests.patch"
-)
-
-python_compile_all() {
- use doc && sphinx-build -b html docs _build/html
-}
-
-python_test() {
- distutils_install_for_testing
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
- PYTEST_PLUGINS=${PN/-/_} \
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( _build/html/. )
- distutils-r1_python_install_all
-}