summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 23:05:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 23:06:06 +0200
commit8e7ec581565a9d59f8b72932442c7a90bfdbe5af (patch)
treeabd7d28abd2ea5ce2b2559194943141a11a7893e /dev-python/pytest-django
parentdev-python/pillow: Bump to 8.0.1 (diff)
downloadgentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.tar.gz
gentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.tar.bz2
gentoo-8e7ec581565a9d59f8b72932442c7a90bfdbe5af.zip
dev-python/pytest-django: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index f9cd0ce843b2..dfde944d9b0e 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,2 +1,3 @@
DIST pytest-django-3.10.0.gh.tar.gz 68995 BLAKE2B dcc9ddceda88c32dab559c065feb347582e72ec5fcd9929cb2bde091bd5c89bbe09879901daf5dc0adc7e38921de5b4989e0d1bbefaa5eb1cdce1dfd2ef58a11 SHA512 7f66fa9287fb80082018613ec3b15a0da3f7a13075e85f0a2eff9e13358c993e56245c441d952d13f232bf7e49a05c799b4affbb844e90abaac736d86bb0a6c9
DIST pytest-django-4.0.0.gh.tar.gz 67041 BLAKE2B 74971186666498a39afca4ad273b932579ce425df439805b6f1e36eadfa916dfaa4affc29ce2987ac62d38ae517140cedbeb9a20c6e13e2362af21878f4694a5 SHA512 411a28b6e2f4cef8a0bae1ce3a937e47fa11728a873ec6a8de6599d02e5a548548ecf56d896600924acfbc0a74c651c66f9d7c4d772ce572879c17bccd3bb27d
+DIST pytest-django-4.1.0.gh.tar.gz 67983 BLAKE2B b7f4fe1366ce1443b19f05e8e834f0555cd8d63bf10921be1427338b7e5e737b7e04d96c9c9d2ad1b9c0f0ed6fba4ed93fb4fd9a948dc5315b4b7a35ba8adfd1 SHA512 734921f5c6f8569f6488706fbb6ca2515a5b24c6641fd260771022bd4fd72b65d062a8130f59163e8b30f4c9bceb383d154b26f8fbf46a1903339668d0a7d12b
diff --git a/dev-python/pytest-django/pytest-django-4.1.0.ebuild b/dev-python/pytest-django/pytest-django-4.1.0.ebuild
new file mode 100644
index 000000000000..7e83c607671a
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.org
+ https://github.com/pytest-dev/pytest-django"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}