summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 14:39:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 15:26:04 +0100
commit90a989a4941d08b1ee6a510bb58db3345ccbecf2 (patch)
tree0e98d5fe969bbb7ec190902644232f70eeb8e04e /dev-python/pytest-django
parentdev-python/sybil: Bump to 1.2.2 (diff)
downloadgentoo-90a989a4941d08b1ee6a510bb58db3345ccbecf2.tar.gz
gentoo-90a989a4941d08b1ee6a510bb58db3345ccbecf2.tar.bz2
gentoo-90a989a4941d08b1ee6a510bb58db3345ccbecf2.zip
dev-python/pytest-django: Bump to 3.8.0, add py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-3.8.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 27f317f75048..4b78b99c3893 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1,2 @@
DIST pytest-django-3.4.4.tar.gz 66962 BLAKE2B a989009eccab4bbd96e32ed1b6b5d03ca8105026c6d9219ea09f6b33fe2087a30d9042e2cd5a313196ed67cc1c5dc940d04fe981dda0da4f25cf16a43e88471a SHA512 a851b27e9abc4829a47abb5da40cbd69fea5c48b05c81f88910d4345696c6d01f78e07ac489cec7cfb5724dd8432891ff9260dc585e720d758491906812661df
+DIST pytest-django-3.8.0.tar.gz 70013 BLAKE2B 75e2ebf6a3a61cfabdc59ceb6f60a85ab4e257b22e3ff55bcda122a370317bf91a9f90640d9edc17da2cc3bdc6dcf6e84dd1e3438dff91b07f5682713804d513 SHA512 3ce45b08f913c3e20b679c7f7a07818ffab7088fd90757794e1807db2025d655c195304da3ca3905c8ddb58fc9708000dc492f4114df8f4e7bfdb1285ebd997a
diff --git a/dev-python/pytest-django/pytest-django-3.8.0.ebuild b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
new file mode 100644
index 000000000000..d8944a9de33a
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"