summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-29 07:46:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-29 07:46:58 +0200
commitaa97d31c076cc50b7114f2a335071a1896aaeda5 (patch)
treec0b121f337f0a3eaff0ee74a23435eb97f6f5584 /dev-python/pytest-django
parentdev-ruby/concurrent-ruby: add 1.1.7 (diff)
downloadgentoo-aa97d31c076cc50b7114f2a335071a1896aaeda5.tar.gz
gentoo-aa97d31c076cc50b7114f2a335071a1896aaeda5.tar.bz2
gentoo-aa97d31c076cc50b7114f2a335071a1896aaeda5.zip
dev-python/pytest-django: Bump to 3.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-3.10.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 1b6ca4c8a95f..a5e9f3e9241f 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1,2 @@
+DIST pytest-django-3.10.0.gh.tar.gz 68995 BLAKE2B dcc9ddceda88c32dab559c065feb347582e72ec5fcd9929cb2bde091bd5c89bbe09879901daf5dc0adc7e38921de5b4989e0d1bbefaa5eb1cdce1dfd2ef58a11 SHA512 7f66fa9287fb80082018613ec3b15a0da3f7a13075e85f0a2eff9e13358c993e56245c441d952d13f232bf7e49a05c799b4affbb844e90abaac736d86bb0a6c9
DIST pytest-django-3.9.0.tar.gz 70498 BLAKE2B 0f3cf7ffd528f00dd0c7dd6babcb64833ec3684c7b62dcb8757b0f90cdcdddabffdbff240774ed6fb2a294e27da2acd7f396298ff2884be6e5b4c8d9c632d008 SHA512 92985e66f47c91363d19fe2bfe8ccab14212be577692f90923dbbae4c8d406cf698796d485af2b721863392810fc07c6f11ada0c61589cd1861f0d34a732effe
diff --git a/dev-python/pytest-django/pytest-django-3.10.0.ebuild b/dev-python/pytest-django/pytest-django-3.10.0.ebuild
new file mode 100644
index 000000000000..0dbf356c69a9
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.org
+ https://github.com/pytest-dev/pytest-django"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}