summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-20 22:55:39 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 01:12:25 -0400
commitf8bdccb1ee551de4b02f3fcb9db9fa71b7a85677 (patch)
tree4660f6631e1bc9ebec10469afc33106f06cfe8b8 /dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
parentsys-kernel/ck-sources: v.bump (4.9.51 & 4.12.14) (diff)
downloadgentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.tar.gz
gentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.tar.bz2
gentoo-f8bdccb1ee551de4b02f3fcb9db9fa71b7a85677.zip
dev-python/pytest-fixture-config: version bump to 1.2.11
Diffstat (limited to 'dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild')
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
new file mode 100644
index 000000000000..a607d181c714
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-fixture-config"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}