summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 09:04:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:10 +0200
commit1567b2ed0eaa4d6b042357803de6aeccc92c5405 (patch)
treea9ad713ae2169764cf9e7a1d1063640efa165001 /dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild
parentdev-python/responses: Bump to 0.15.0 (diff)
downloadgentoo-1567b2ed0eaa4d6b042357803de6aeccc92c5405.tar.gz
gentoo-1567b2ed0eaa4d6b042357803de6aeccc92c5405.tar.bz2
gentoo-1567b2ed0eaa4d6b042357803de6aeccc92c5405.zip
dev-python/pytest-flakes: Bump to 4.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild')
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild
new file mode 100644
index 000000000000..ccb22189a668
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/pytest-flakes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest