summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2019-02-01 15:22:31 +0000
committerTony Vroon <chainsaw@gentoo.org>2019-02-01 15:52:12 +0000
commitccff5283852294ce22206ecd509a54375ca8e4c6 (patch)
treeb2518c8bbacc9e213d01ef00f90d7bf25e7ed680 /dev-python/pytest-flakes
parentdev-lang/go: remove vulnerable versions (diff)
downloadgentoo-ccff5283852294ce22206ecd509a54375ca8e4c6.tar.gz
gentoo-ccff5283852294ce22206ecd509a54375ca8e4c6.tar.bz2
gentoo-ccff5283852294ce22206ecd509a54375ca8e4c6.zip
dev-python/pytest-flakes: Initial commit.
Dependency for dev-python/python-utils. Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/pytest-flakes')
-rw-r--r--dev-python/pytest-flakes/Manifest1
-rw-r--r--dev-python/pytest-flakes/metadata.xml12
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild24
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/Manifest b/dev-python/pytest-flakes/Manifest
new file mode 100644
index 000000000000..d32b5978ded5
--- /dev/null
+++ b/dev-python/pytest-flakes/Manifest
@@ -0,0 +1 @@
+DIST pytest-flakes-4.0.0.tar.gz 7138 BLAKE2B e3c43df60484c664672f8b9ea92f8d4e25ae33e0dffc9cee200867220a3c8840f7325be28a4bec44918a9b44c1d73d3b89517db8dfa9bb982ed92a34c3b09674 SHA512 e74fe78e713040e3e85f206e8d26f5b8d8ef27dd94c2afccf3cd0f1f982c5e6c30c5966f2cdb774c7a2a8052d1a5cb324626b1997a9e75f5a7bb7d4a5e99376a
diff --git a/dev-python/pytest-flakes/metadata.xml b/dev-python/pytest-flakes/metadata.xml
new file mode 100644
index 000000000000..9d43655030c4
--- /dev/null
+++ b/dev-python/pytest-flakes/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pytest-flakes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild
new file mode 100644
index 000000000000..976094bbe3ae
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" ./test_flakes.py || die "Tests failed under ${EPYTHON}"
+}