summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 11:48:50 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 11:57:02 +0100
commite1fc160d7541f19b3a7cdcc56eafe169978594ca (patch)
treecc9ca5bb20a7898de816971d733171014f2f2675 /dev-python/pytest-html/pytest-html-3.1.1.ebuild
parentsys-apps/sandbox: Remove old (diff)
downloadgentoo-e1fc160d7541f19b3a7cdcc56eafe169978594ca.tar.gz
gentoo-e1fc160d7541f19b3a7cdcc56eafe169978594ca.tar.bz2
gentoo-e1fc160d7541f19b3a7cdcc56eafe169978594ca.zip
dev-python/pytest-html: add 3.1.1
Invoking maintainer time-out. Builds and installs fine against python3_10, have also successfully run the test suite using tox. Bug: https://bugs.gentoo.org/759931 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-html/pytest-html-3.1.1.ebuild')
-rw-r--r--dev-python/pytest-html/pytest-html-3.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-html/pytest-html-3.1.1.ebuild b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
new file mode 100644
index 000000000000..052856b3ca2f
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Lots of test failures...
+RESTRICT="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}