summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-07 16:14:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-07 16:14:34 +0300
commitb289ad9e2a802031517b0c07e4c316aab4e92334 (patch)
treef53462ee25f30fcd9052b739d05327f9a99618f2 /dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild
parentsci-visualization/kst: Fix dependencies, add missing usedep (diff)
downloadgentoo-b289ad9e2a802031517b0c07e4c316aab4e92334.tar.gz
gentoo-b289ad9e2a802031517b0c07e4c316aab4e92334.tar.bz2
gentoo-b289ad9e2a802031517b0c07e4c316aab4e92334.zip
dev-python/pytest-metadata: add 1.11.0, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild b/dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild
new file mode 100644
index 000000000000..eee2b6544974
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-1.11.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="https://github.com/pytest-dev/pytest-metadata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest