summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-31 20:03:17 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-31 20:03:17 -0500
commit188f6a2146ca1fdbdf197e625b615823656f3cf6 (patch)
tree740c847a8ec9747e545de92c90d423f5fd16bd19 /dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild
parentdev-python/stormpath: remove version 2.0.8 (diff)
downloadgentoo-188f6a2146ca1fdbdf197e625b615823656f3cf6.tar.gz
gentoo-188f6a2146ca1fdbdf197e625b615823656f3cf6.tar.bz2
gentoo-188f6a2146ca1fdbdf197e625b615823656f3cf6.zip
dev-python/pytest-raisesregexp: add version 2.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild')
-rw-r--r--dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild b/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild
new file mode 100644
index 000000000000..95d8396250d5
--- /dev/null
+++ b/dev-python/pytest-raisesregexp/pytest-raisesregexp-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple pytest plugin to look for regex in Exceptions"
+HOMEPAGE="https://github.com/Walkman/pytest_raisesregexp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${CDEPEND} )
+"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/py[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${PYTHON} -m pytest || die "Tests failed under ${EPYTHON}"
+}