summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 14:27:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 22:45:52 +0100
commit63792620ae8d8cbb153fe7b15a6a8a28c285046f (patch)
tree323963e785b35958a1b2f40015315e3c90aaf7c8 /dev-python/pytest-runner
parentnet-dns/getdns: Remove old (diff)
downloadgentoo-63792620ae8d8cbb153fe7b15a6a8a28c285046f.tar.gz
gentoo-63792620ae8d8cbb153fe7b15a6a8a28c285046f.tar.bz2
gentoo-63792620ae8d8cbb153fe7b15a6a8a28c285046f.zip
dev-python/pytest-runner: Drop 2.11.1, 2.6.2, 4.0
4.2 is stable, EAPI-5 cleanup. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pytest-runner')
-rw-r--r--dev-python/pytest-runner/Manifest3
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.11.1.ebuild40
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.6.2.ebuild43
-rw-r--r--dev-python/pytest-runner/pytest-runner-4.0.ebuild42
4 files changed, 0 insertions, 128 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
index d024ac74ad5e..339a44280769 100644
--- a/dev-python/pytest-runner/Manifest
+++ b/dev-python/pytest-runner/Manifest
@@ -1,5 +1,2 @@
-DIST pytest-runner-2.11.1.tar.gz 9661 BLAKE2B 300b63de61ef36c299a95c60af469b071c27ae483f641c7cad594f7b6f582d9e1e076192f9fd5019850cf9227af183e9f80b4049719d074a180e72c25521bc14 SHA512 5249e0a368bab21bb034a9b0121edbcda635f559cc22ba79c87565dcbc070056bfed47a69c16f4733403f61ea5b73adfd1ccf945700116043cbf3940d37d4067
-DIST pytest-runner-2.6.2.tar.gz 6379 BLAKE2B 4f676a4cd59309cdd0e6462c83718482622817781d302ed95a2b7cb9d92a0b0f38b411c1172ecce9003f5781cdb168338bce6f446b1c91069a2024fb75574bfc SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d
-DIST pytest-runner-4.0.tar.gz 11401 BLAKE2B 3be4527e68b8c1ae7e1bb5bad111367e459a07cf20de1f3b2d8ab993a7e016f9656618075bf515f576fef457aa86f99990f7dcc4c20a04166703bf9272c395c1 SHA512 a7f3defcc698f43b3b6ceec3f59dbd0e00c651167ddc76a9d1a093d722a013c9ffd2bad3438e49170688d503166cb6d8bf55bbaf7bc6f9e6d80eff049c202b08
DIST pytest-runner-4.2.tar.gz 11947 BLAKE2B 97495bead800a81d879659f1ee522822f76fe8ac80579537d43e21e663323d7c10be8d2da7d05ffdb0931145149d8c10ef7c72b3ab4da2ce856d44d3f00a724e SHA512 278da7add27f77134e63470747ffd9fe663d93ab8e7cebfbae98902bb1d5ffba45277574107f958255251cb9e499b85a0db3e8173f9f10fb31d1561ca709a379
DIST pytest-runner-5.2.tar.gz 15534 BLAKE2B 0bcbd5991808aaa4b85b9071ce142e03287683e919687fa76f5b7929ad07dca6ae6edaf7ad30a1bc1ba0163f43505ec18ab2cd5e0462399b8252c8ca761d7b29 SHA512 5fc62a4e681cfa0ef25dc815ccbbfe1a7ca0e9e7783c2ba2db0da7d2539f11c08d6c3fad2ab3dfe7f0d50fe7bfb41127b11ec9af67ef8e32361655bc910c8245
diff --git a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
deleted file mode 100644
index 746367bac74c..000000000000
--- a/dev-python/pytest-runner/pytest-runner-2.11.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? (
- dev-python/rst-linker[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- esetup.py pytest
-}
diff --git a/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild b/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild
deleted file mode 100644
index 476f6b3fba46..000000000000
--- a/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-SLOT="0"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- "
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-
-# Test not included
-RESTRICT="test"
-
-python_compile_all() {
- # The build by rst2html.py makes non fatal errors building index.rst
- if use doc; then
- rst2html.py docs/history.rst > docs/history.html
- rst2html.py docs/index.rst > docs/index.html
- fi
-}
-
-python_test() {
- esetup.py pytest
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pytest-runner/pytest-runner-4.0.ebuild b/dev-python/pytest-runner/pytest-runner-4.0.ebuild
deleted file mode 100644
index edf96aa5c9eb..000000000000
--- a/dev-python/pytest-runner/pytest-runner-4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? (
- dev-python/rst-linker[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( ${RDEPEND} )
-"
-
-# Tests require network access to download packages
-RESTRICT="test"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- esetup.py pytest || die
-}