summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-25 10:43:02 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-25 13:23:39 +0200
commit6e6d1ba4353f6049694c6e44d249eeaff32881cb (patch)
tree2e1358f5b11405d5d7ca0aeb8f9fab565707f249 /dev-python/pytest-shell-utilities
parentdev-python/pytest-skip-markers: new package, add 1.2.0 (diff)
downloadgentoo-6e6d1ba4353f6049694c6e44d249eeaff32881cb.tar.gz
gentoo-6e6d1ba4353f6049694c6e44d249eeaff32881cb.tar.bz2
gentoo-6e6d1ba4353f6049694c6e44d249eeaff32881cb.zip
dev-python/pytest-shell-utilities: new package, add 1.0.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest1
-rw-r--r--dev-python/pytest-shell-utilities/metadata.xml13
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild48
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
new file mode 100644
index 000000000000..78a39cf489f6
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -0,0 +1 @@
+DIST pytest-shell-utilities-1.0.5.gh.tar.gz 89489 BLAKE2B 9cd7f95c9c1691e19c320378d1c2a4e147cb6fdc35ec6f3c80dc288e70416fce67b60ac86427f1ad322b2c17de3cd762e483d63076fa291b4b7d22d7a29c9e45 SHA512 395107af9eaa13ef39d01858e1674b6dedddc2cf93b9aba61316fd8d847031e1b535cc3bf4f2899dbc7828609b7d45b500aad29bb47668be6e0453ac099e99e4
diff --git a/dev-python/pytest-shell-utilities/metadata.xml b/dev-python/pytest-shell-utilities/metadata.xml
new file mode 100644
index 000000000000..8a6326c310a5
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-shell-utilities</remote-id>
+ <remote-id type="github">saltstack/pytest-shell-utilities</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild
new file mode 100644
index 000000000000..26d3ba50da9f
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to simplify running shell commands against the system"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ !!<dev-python/pytest-salt-factories-0.912.2
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/setuptools-declarative-requirements/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}