summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:54:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 23:37:13 +0300
commit700860f5d4e017c8208502a4285baca8f694d60c (patch)
tree2e18ac2e517988dc059996d10cf066641a70461f /dev-python/pytest-sugar
parentapp-doc/doxygen: add 1.9.4 (diff)
downloadgentoo-700860f5d4e017c8208502a4285baca8f694d60c.tar.gz
gentoo-700860f5d4e017c8208502a4285baca8f694d60c.tar.bz2
gentoo-700860f5d4e017c8208502a4285baca8f694d60c.zip
dev-python/pytest-sugar: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-sugar')
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.4-r1.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..0fed89e9b545
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that changes the default look and feel of py.test"
+HOMEPAGE="https://github.com/Teemu/pytest-sugar https://pypi.org/project/pytest-sugar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest