summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-09 18:38:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-09 18:48:11 +0200
commit2971e1c16688833f59ad3f782c2cf290dd2ea946 (patch)
treecf3ac19f65ba371752fb1888172e754509ff1a43 /dev-python/pytest-timeout
parentdev-python/pexpect: Enable py3.13 (diff)
downloadgentoo-2971e1c16688833f59ad3f782c2cf290dd2ea946.tar.gz
gentoo-2971e1c16688833f59ad3f782c2cf290dd2ea946.tar.bz2
gentoo-2971e1c16688833f59ad3f782c2cf290dd2ea946.zip
dev-python/pytest-timeout: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
index 2d48986cbf02..cd7abe388b7d 100644
--- a/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-2.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -25,7 +25,9 @@ BDEPEND="
test? (
dev-python/pexpect[${PYTHON_USEDEP}]
!hppa? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' python3_{10..11} pypy3)
)
)
"
@@ -37,7 +39,7 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_timeout
- if has_version dev-python/pytest-cov; then
+ if has_version "dev-python/pytest-cov[${PYTHON_USEDEP}]"; then
PYTEST_PLUGINS+=,pytest_cov.plugin
else
EPYTEST_DESELECT+=(