summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-19 20:32:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-19 20:32:38 +0200
commit96a4fc032ab655129a4932c28c4b99c111625d81 (patch)
tree87066cf59f7554273ee6f4896aad08a72ed5c67a /dev-python/pytest-timeout
parentsci-misc/netlogo-bin: update DESCRIPTION and HOMEPAGE (diff)
downloadgentoo-96a4fc032ab655129a4932c28c4b99c111625d81.tar.gz
gentoo-96a4fc032ab655129a4932c28c4b99c111625d81.tar.bz2
gentoo-96a4fc032ab655129a4932c28c4b99c111625d81.zip
dev-python/pytest-timeout: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.4.2-r1.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.4.2-r1.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.4.2-r1.ebuild
index 6502bfc16013..ab58b250128b 100644
--- a/dev-python/pytest-timeout/pytest-timeout-1.4.2-r1.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-1.4.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -22,17 +22,11 @@ BDEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
!hppa? ( $(python_gen_cond_dep '
dev-python/pytest-cov[${PYTHON_USEDEP}]
- ' -3) )
+ ' python3_{7..9}) )
)"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
PATCHES=(
"${FILESDIR}"/pytest-timeout-1.4.2-optional-cov.patch
)
-
-python_test() {
- distutils_install_for_testing
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}