summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-14 09:23:24 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-15 08:12:10 +0300
commit2ea155fd979e0b6a2209abba23c7289a132e9043 (patch)
tree1198685d429938444047d1a9cba93bad0c294c09 /dev-python/pytest-toolbox
parentwww-client/chromium: Stabilize 93.0.4577.82 arm64, #813064 (diff)
downloadgentoo-2ea155fd979e0b6a2209abba23c7289a132e9043.tar.gz
gentoo-2ea155fd979e0b6a2209abba23c7289a132e9043.tar.bz2
gentoo-2ea155fd979e0b6a2209abba23c7289a132e9043.zip
dev-python/pytest-toolbox: initial import
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-toolbox')
-rw-r--r--dev-python/pytest-toolbox/Manifest1
-rw-r--r--dev-python/pytest-toolbox/metadata.xml12
-rw-r--r--dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-toolbox/Manifest b/dev-python/pytest-toolbox/Manifest
new file mode 100644
index 000000000000..d3d4b309cf77
--- /dev/null
+++ b/dev-python/pytest-toolbox/Manifest
@@ -0,0 +1 @@
+DIST pytest-toolbox-0.4.gh.tar.gz 8594 BLAKE2B fb1f19513e9e4b191c3eb995cc5e9445bc9f19affef87350d925c5465210c4de945b91120f86664c1dcf02a638595a7725cf88e3244e377ae77558c70d65643a SHA512 ed27700ff77cd607be808142cc310cd2b7461e55b3f8352d304ef8ca6c5e6c060c67a63238a1025407868ab8e229c4a16eaaa56aa75000159762001accb67752
diff --git a/dev-python/pytest-toolbox/metadata.xml b/dev-python/pytest-toolbox/metadata.xml
new file mode 100644
index 000000000000..0b43cf3a3e28
--- /dev/null
+++ b/dev-python/pytest-toolbox/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-toolbox</remote-id>
+ <remote-id type="github">samuelcolvin/pytest-toolbox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
new file mode 100644
index 000000000000..ffff5bfb4ec7
--- /dev/null
+++ b/dev-python/pytest-toolbox/pytest-toolbox-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Numerous useful plugins for pytest"
+HOMEPAGE="https://pypi.org/project/pytest-toolbox/ https://github.com/samuelcolvin/pytest-toolbox/"
+SRC_URI="
+ https://github.com/samuelcolvin/pytest-toolbox/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}