summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 14:35:16 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 14:40:02 +0100
commitaa09f71c879fe132b8148b7ce2e500d8914094da (patch)
tree6a0d47afe09ec3b92008a33460413cbe6a9bc230 /dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
parentdev-python/cerberus: tag as ALLARCH in metadata (diff)
downloadgentoo-aa09f71c879fe132b8148b7ce2e500d8914094da.tar.gz
gentoo-aa09f71c879fe132b8148b7ce2e500d8914094da.tar.bz2
gentoo-aa09f71c879fe132b8148b7ce2e500d8914094da.zip
dev-python/pytest-verbose-parametrize: initial import
The test suite doesn't work properly (even when run manually) but fails in exactly the same way for all three supported Python implementations. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild')
-rw-r--r--dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild b/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
new file mode 100644
index 000000000000..eca528e91615
--- /dev/null
+++ b/dev-python/pytest-verbose-parametrize/pytest-verbose-parametrize-1.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="More descriptive parametrized-test IDs for py.test"
+HOMEPAGE="https://github.com/man-group/pytest-plugins https://pypi.org/project/pytest-verbose-parametrize/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The test suite is borked, some of the tests are extremely sensitive to Python
+# verbosity level whereas others act differently depending on whether the package
+# has previously been installed or not.
+RESTRICT="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0_collections-abc.patch
+)
+
+distutils_enable_tests pytest