summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-02-18 12:12:54 -0500
committerMike Gilbert <floppym@gentoo.org>2017-02-18 12:13:11 -0500
commit0d0f8ba34d9809e980807c9bd76d46c5c00a97a1 (patch)
treeb2828d3433cc386fc57cf14a6974c3000081ee62 /dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
parentmedia-sound/aqualung: Add USE=libav (diff)
downloadgentoo-0d0f8ba34d9809e980807c9bd76d46c5c00a97a1.tar.gz
gentoo-0d0f8ba34d9809e980807c9bd76d46c5c00a97a1.tar.bz2
gentoo-0d0f8ba34d9809e980807c9bd76d46c5c00a97a1.zip
dev-python/pytest-xdist: fix test_manytests_to_one_import_error
Bug: https://bugs.gentoo.org/597700 Package-Manager: Portage-2.3.3_p56, Repoman-2.3.1_p49
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
index 105194a271fa..27b6a3d48e52 100644
--- a/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-1.15.0.ebuild
@@ -32,6 +32,10 @@ DEPEND="${RDEPEND}
)
"
+PATCHES=(
+ "${FILESDIR}"/1.15.0-test_manytests_to_one_import_error.patch
+)
+
python_test() {
find -name __pycache__ -exec rm -r '{}' + || die
py.test -vv || die "Tests failed under ${EPYTHON}"