summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-12-18 10:03:58 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-12-18 12:13:08 +0100
commit0b307cecf4c964cd903186dcf2fd05801457286c (patch)
treef782bd734b54f79d401303882fd9d25697a27864 /dev-python/pytest-xdist
parentsys-devel/gcc: amd64 stable wrt bug #758437 (diff)
downloadgentoo-0b307cecf4c964cd903186dcf2fd05801457286c.tar.gz
gentoo-0b307cecf4c964cd903186dcf2fd05801457286c.tar.bz2
gentoo-0b307cecf4c964cd903186dcf2fd05801457286c.zip
dev-python/pytest-xdist: add dependency on pytest >= 6
pytest-xdist >= 2 won't work with pytest < 6, it will show "INTERNALERROR" messages. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..deaa5ddb4ecb
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-services-conflict.patch
+)
+
+distutils_enable_tests --install pytest