summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 21:13:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 21:47:07 +0200
commit2e11b0810b30f5e8044e14bd5d1aaf34dd50490d (patch)
treed8321b84377056e8c2e4229069166b2824d8f9ac /dev-python/pytest-xdist
parentmedia-libs/libjpeg-turbo: add patch for arm64 writable sections (diff)
downloadgentoo-2e11b0810b30f5e8044e14bd5d1aaf34dd50490d.tar.gz
gentoo-2e11b0810b30f5e8044e14bd5d1aaf34dd50490d.tar.bz2
gentoo-2e11b0810b30f5e8044e14bd5d1aaf34dd50490d.zip
dev-python/pytest-xdist: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index d7237d4514f2..908acf5fdaee 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1 +1,2 @@
DIST pytest-xdist-2.3.0.tar.gz 66072 BLAKE2B 367ff15cd46b8594668ccd9710a2fc7665295d41e268b464b81d5e740a580d70621a1ab5ab590788e44887b7aa3049a83853ea097c0cff54e22c3422c8f11b24 SHA512 bf49a1684b29f0ae21621b9d293f530cf2fa3d88b33f631fb803aef872c0d5ef6b3bbf2e16d01be8a6c1872fe3e6cff86ab842e3000b9e642fb46c2a170627f6
+DIST pytest-xdist-2.4.0.tar.gz 67199 BLAKE2B bba867bfbd1e161ada2157fdb5a10f929fefed959b64afef74453206d91e5014abaaa1363ac9adbc89ed476a841607f6830781817842b9be119a09bda7278b91 SHA512 2d2da6aaa8da07a28d7c6c81a0044493b7d0d1a68921e7ec94cfd2f698eaa5594b6da4d82524804637d5cc061fbe19034f3c65a07ee5a0c906170856edc3d383
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
new file mode 100644
index 000000000000..5415cb9cc80c
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# pytest-xdist >= 2 fails with pytest < 6
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ distutils_install_for_testing
+ epytest
+}