summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-15 11:14:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-15 12:05:40 +0100
commit3d5fe5dd30bb764d3f097d2252e9322679f414ab (patch)
tree0c9f4ed123c523b65163d74d63ea6dbc6c2239d2 /dev-python/pytest-xdist
parentdev-python/sshtunnel: Remove old (diff)
downloadgentoo-3d5fe5dd30bb764d3f097d2252e9322679f414ab.tar.gz
gentoo-3d5fe5dd30bb764d3f097d2252e9322679f414ab.tar.bz2
gentoo-3d5fe5dd30bb764d3f097d2252e9322679f414ab.zip
dev-python/pytest-xdist: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 1a85694e4cdd..ef25b548c207 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xdist-1.34.0.tar.gz 66151 BLAKE2B ac5274e32b3ef6b72113efd4300eb6946a977e0e202d3383abcdbc022126b7806edb326ddc16abb1219e22eb091e06a9c39fce3031aaf5943d4ad653a47af142 SHA512 69e9877ee0268d71d7c0ca202ccc46b3ba1a9271f0e6e4ac4b76602833f9b7012364eb6924ae994e76c1d48d63adf1702d4c5e6ed5b75c52ac7ebae958210e24
DIST pytest-xdist-2.1.0.tar.gz 66332 BLAKE2B ac3c19a32bb9153537edfcf55bc656011661cf0d166da1aba969055a398616bb5782534a12ba354175be722c070fcfb2013d58405048814a3d11434a314e38b8 SHA512 85c69d8e649a19de5639738eae4cb213dc7323d96883ec82f39ab51a196346edd9fadbaf97f9763ac0dea104bc123d521264a39d2701878edfa76ce7e5bb347b
+DIST pytest-xdist-2.2.0.tar.gz 64781 BLAKE2B 17287c28f31c42c6a8fe3622d4ba920a530e0ced3bc99cffd8f9de91c3498cc2a3b654cc32bd5b09ee8ec6c1f64226aec736acafd73397be2eb34bd3d192bb46 SHA512 2027f8512fbd6cb68ab36eb774b9d8b7e855c181733b884f394d0e84994926b4fe6158dbd55808328b262497036f101e71cb86553340eba0031d654f34541689
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.2.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.2.0.ebuild
new file mode 100644
index 000000000000..6bd046986b60
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# please do not depend on pytest to avoid unnecessary USEDEP enforcement
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest