summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:02:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:12:57 +0300
commita7035f4c43053a889fe40d32edb923f64796ad52 (patch)
treed41c4fa913b10f8339f007bc77f9bcc34aa47698 /dev-python/pytest-xdist
parentdev-python/jupyter_core: drop 4.7.1 (diff)
downloadgentoo-a7035f4c43053a889fe40d32edb923f64796ad52.tar.gz
gentoo-a7035f4c43053a889fe40d32edb923f64796ad52.tar.bz2
gentoo-a7035f4c43053a889fe40d32edb923f64796ad52.zip
dev-python/pytest-xdist: drop 2.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 908acf5fdaee..c5c6980f93bc 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1 @@
-DIST pytest-xdist-2.3.0.tar.gz 66072 BLAKE2B 367ff15cd46b8594668ccd9710a2fc7665295d41e268b464b81d5e740a580d70621a1ab5ab590788e44887b7aa3049a83853ea097c0cff54e22c3422c8f11b24 SHA512 bf49a1684b29f0ae21621b9d293f530cf2fa3d88b33f631fb803aef872c0d5ef6b3bbf2e16d01be8a6c1872fe3e6cff86ab842e3000b9e642fb46c2a170627f6
DIST pytest-xdist-2.4.0.tar.gz 67199 BLAKE2B bba867bfbd1e161ada2157fdb5a10f929fefed959b64afef74453206d91e5014abaaa1363ac9adbc89ed476a841607f6830781817842b9be119a09bda7278b91 SHA512 2d2da6aaa8da07a28d7c6c81a0044493b7d0d1a68921e7ec94cfd2f698eaa5594b6da4d82524804637d5cc061fbe19034f3c65a07ee5a0c906170856edc3d383
diff --git a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
deleted file mode 100644
index 883e7c88dcea..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-2.3.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# pytest-xdist >= 2 fails with pytest < 6
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-services-conflict.patch
-)
-
-distutils_enable_tests --install pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- distutils_install_for_testing
- epytest
-}