summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-27 09:50:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-27 10:20:20 +0100
commit51555bbdeb1d53ad0e6515e5c04563e55f3ed9d4 (patch)
treed4dfd87ff9da1365f55e79ee58b2a047dc7cd84c /dev-python/pytest-xprocess
parentdev-python/lxml: Bump to 4.6.2 (diff)
downloadgentoo-51555bbdeb1d53ad0e6515e5c04563e55f3ed9d4.tar.gz
gentoo-51555bbdeb1d53ad0e6515e5c04563e55f3ed9d4.tar.bz2
gentoo-51555bbdeb1d53ad0e6515e5c04563e55f3ed9d4.zip
dev-python/pytest-xprocess: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.17.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 4d67ee2f3808..dbae0f14ed48 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xprocess-0.15.0.tar.gz 13512 BLAKE2B 97ffef1e63f50ad2a1651f1791663f99e39c8fd8fc63427534efa5d60c9a4d856b7e036cd03faed73a1ba609716595ceeefe63604403a2bbd8a13407612a6402 SHA512 d2c7f6859b1696a8cb4445396376ce36bdcfdc8677fd97def716f240ae243c954f4110a3e500315a7f0c7f7ab7c337bf6749cbd1df3485db9fb95f42c2ffd181
DIST pytest-xprocess-0.16.0.tar.gz 17218 BLAKE2B 60411ed5af2add7f7c7f6b6e2074f9703cdae8a450c65eda483635a1cf8f60a3dbd84218d9e99bb3783ae00ba50b3449335df92397dab0fc7281ea72d3f5696b SHA512 3cf5d05c6693ebddc91fb2ad62eacd5b8f231e78ee82908b20268367649d6d73f0c1fbbf93a31f97feabe8bddf02cb176b2ffb9f6de4387b46cd0b97ad3c3eea
+DIST pytest-xprocess-0.17.0.tar.gz 19186 BLAKE2B 071063267d88d8ddd56c3b8ab7b2e6bebae321ac741e63336721cd13045688cef56909737c73b5cec27805b4f7dd93cdd7f467071966b3d864d0a1f270e821d0 SHA512 c85bb7bd8373b5b5119083fca46b8f173efe3b6f6cde5db8365e567e717f47f6f9230d2cf5ecfddb014aedd628aee75023f4da3077fa3ffb26b3c7bfc61d57c9
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.17.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.17.0.ebuild
new file mode 100644
index 000000000000..d9f406cc465b
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.17.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest