summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 14:33:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 14:58:56 +0100
commita386630c2a1a76febe56186da3235aef67946f61 (patch)
tree0af434a740bde2e08f0619587a1cd055b9b8ba34 /dev-python/pytest-xprocess
parentdev-python/pytest-xprocess: Stabilize 0.12.1-r2 ALLARCHES (diff)
downloadgentoo-a386630c2a1a76febe56186da3235aef67946f61.tar.gz
gentoo-a386630c2a1a76febe56186da3235aef67946f61.tar.bz2
gentoo-a386630c2a1a76febe56186da3235aef67946f61.zip
dev-python/pytest-xprocess: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild32
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild34
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
deleted file mode 100644
index ca8f808077c8..000000000000
--- a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-python_test() {
- # Upstream's package mistakenly includes __pycache__ directory that make
- # tests fail.
- rm -rf example/__pycache__ || die
- pytest -v || die
-}
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
deleted file mode 100644
index e8c4207e4ef8..000000000000
--- a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage external processes across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- || (
- dev-python/pytest-cache[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
- )
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- PYTEST_PLUGINS="pytest_xprocess" py.test -v -v || die
-}