summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-28 13:29:12 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-28 13:29:34 -0400
commit8a461c82a13e1a2b88acd845122f1960a8d04491 (patch)
treeac0f234b0e5c425d613d242fd064be26e34b7abe /dev-python/pytest/pytest-3.0.3.ebuild
parentdev-python/pytest: remove live ebuild (diff)
downloadgentoo-8a461c82a13e1a2b88acd845122f1960a8d04491.tar.gz
gentoo-8a461c82a13e1a2b88acd845122f1960a8d04491.tar.bz2
gentoo-8a461c82a13e1a2b88acd845122f1960a8d04491.zip
dev-python/pytest: disable test_pdb
This test hangs/errors in an ebuild environment, but works fine outside of an ebuild. Bug: https://bugs.gentoo.org/598442 Package-Manager: Portage-2.3.6_p1, Repoman-2.3.2_p69
Diffstat (limited to 'dev-python/pytest/pytest-3.0.3.ebuild')
-rw-r--r--dev-python/pytest/pytest-3.0.3.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/pytest/pytest-3.0.3.ebuild b/dev-python/pytest/pytest-3.0.3.ebuild
index 2d267397c09b..61fe2a0d9fb8 100644
--- a/dev-python/pytest/pytest-3.0.3.ebuild
+++ b/dev-python/pytest/pytest-3.0.3.ebuild
@@ -46,6 +46,9 @@ python_prepare_all() {
sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
distutils-r1_python_prepare_all
}