summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-03 21:46:17 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-03 21:46:17 +0100
commit3b7907c5803f3cff8448cb739325678bbbc9b828 (patch)
tree52711a7c1b0ce38944a82594c36eb546e56ed6de /dev-python/pytest
parentdev-python/jaraco-text: Remove python_gen_cond_dep calls for py3.5 (diff)
downloadgentoo-3b7907c5803f3cff8448cb739325678bbbc9b828.tar.gz
gentoo-3b7907c5803f3cff8448cb739325678bbbc9b828.tar.bz2
gentoo-3b7907c5803f3cff8448cb739325678bbbc9b828.zip
dev-python/pytest: Remove python_gen_cond_dep calls for py3.5
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.10.1.ebuild6
-rw-r--r--dev-python/pytest/pytest-4.5.0.ebuild2
-rw-r--r--dev-python/pytest/pytest-4.6.6.ebuild4
-rw-r--r--dev-python/pytest/pytest-4.6.7.ebuild6
-rw-r--r--dev-python/pytest/pytest-4.6.8.ebuild4
-rw-r--r--dev-python/pytest/pytest-5.3.0.ebuild3
-rw-r--r--dev-python/pytest/pytest-5.3.1.ebuild3
-rw-r--r--dev-python/pytest/pytest-5.3.2.ebuild3
8 files changed, 14 insertions, 17 deletions
diff --git a/dev-python/pytest/pytest-3.10.1.ebuild b/dev-python/pytest/pytest-3.10.1.ebuild
index 551cebba719d..743c17f71e9f 100644
--- a/dev-python/pytest/pytest-3.10.1.ebuild
+++ b/dev-python/pytest/pytest-3.10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,8 +27,8 @@ RDEPEND="
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python2_7 )
$(python_gen_cond_dep '<dev-python/more-itertools-6.0.0[${PYTHON_USEDEP}]' python2_7 )
- $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python3_{5,6,7} pypy{,3} )
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7 python3_5 )
+ $(python_gen_cond_dep '>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]' python3_{6,7} pypy{,3} )
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)
>=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
>=dev-python/setuptools-40[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-4.5.0.ebuild b/dev-python/pytest/pytest-4.5.0.ebuild
index e5795dd521d4..7e4a0403ce2d 100644
--- a/dev-python/pytest/pytest-4.5.0.ebuild
+++ b/dev-python/pytest/pytest-4.5.0.ebuild
@@ -26,7 +26,7 @@ RDEPEND="
>=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7 python3_5 )
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)
>=dev-python/pluggy-0.11[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-4.6.6.ebuild b/dev-python/pytest/pytest-4.6.6.ebuild
index 4f85c1855b6c..00edbafb3277 100644
--- a/dev-python/pytest/pytest-4.6.6.ebuild
+++ b/dev-python/pytest/pytest-4.6.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,7 +28,7 @@ RDEPEND="
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
-2 python3_{5,6,7} pypy3)
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2 python3_5)
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-4.6.7.ebuild b/dev-python/pytest/pytest-4.6.7.ebuild
index 4f85c1855b6c..0efddd35ef8c 100644
--- a/dev-python/pytest/pytest-4.6.7.ebuild
+++ b/dev-python/pytest/pytest-4.6.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,8 +27,8 @@ RDEPEND="
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
- -2 python3_{5,6,7} pypy3)
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2 python3_5)
+ -2 python3_{6,7} pypy3)
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-4.6.8.ebuild b/dev-python/pytest/pytest-4.6.8.ebuild
index 4f85c1855b6c..00edbafb3277 100644
--- a/dev-python/pytest/pytest-4.6.8.ebuild
+++ b/dev-python/pytest/pytest-4.6.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,7 +28,7 @@ RDEPEND="
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' \
-2 python3_{5,6,7} pypy3)
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2 python3_5)
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-5.3.0.ebuild b/dev-python/pytest/pytest-5.3.0.ebuild
index 9795396ca686..87b412ee4468 100644
--- a/dev-python/pytest/pytest-5.3.0.ebuild
+++ b/dev-python/pytest/pytest-5.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,6 @@ RDEPEND="
dev-python/importlib_metadata[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-5.3.1.ebuild b/dev-python/pytest/pytest-5.3.1.ebuild
index 9795396ca686..87b412ee4468 100644
--- a/dev-python/pytest/pytest-5.3.1.ebuild
+++ b/dev-python/pytest/pytest-5.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,6 @@ RDEPEND="
dev-python/importlib_metadata[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-5.3.2.ebuild b/dev-python/pytest/pytest-5.3.2.ebuild
index 76a95d4f3d73..835e9d7c96e1 100644
--- a/dev-python/pytest/pytest-5.3.2.ebuild
+++ b/dev-python/pytest/pytest-5.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,7 +27,6 @@ RDEPEND="
dev-python/importlib_metadata[${PYTHON_USEDEP}]
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
<dev-python/pluggy-1
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]