summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-bugzilla
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/metadata.xml8
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-1.1.0.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
new file mode 100644
index 000000000000..8a57ce408e23
--- /dev/null
+++ b/dev-python/python-bugzilla/Manifest
@@ -0,0 +1 @@
+DIST python-bugzilla-1.1.0.tar.gz 70841 SHA256 7e24b50269a994b77463575a75dd5c91a892ebc669289171bef4e0193f3d9549 SHA512 30192d6c1e76f3a79b5059916ad773704e6ce503d5d44fbc9e5d7b4ac18b062108d336d8d2e0d26e4cd21ba421fc607e4b3ca2bd5a1e362561708c05b8322d88 WHIRLPOOL 1a2209b89125807cfd6db9258c2a2ee87641921316d8f2dd9123c28f90ca78f52241e1ead9fda392cc026421fd84244418791150cdca6cf07d9f86a4a34b134e
diff --git a/dev-python/python-bugzilla/metadata.xml b/dev-python/python-bugzilla/metadata.xml
new file mode 100644
index 000000000000..84b639aeb862
--- /dev/null
+++ b/dev-python/python-bugzilla/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-bugzilla/python-bugzilla-1.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-1.1.0.ebuild
new file mode 100644
index 000000000000..e6de1476ddfc
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-1.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://fedorahosted.org/python-bugzilla/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]
+"