summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-catcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-catcher')
-rw-r--r--dev-python/python-catcher/Manifest1
-rw-r--r--dev-python/python-catcher/metadata.xml11
-rw-r--r--dev-python/python-catcher/python-catcher-0.1.7.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-catcher/Manifest b/dev-python/python-catcher/Manifest
new file mode 100644
index 000000000000..398f639cdf67
--- /dev/null
+++ b/dev-python/python-catcher/Manifest
@@ -0,0 +1 @@
+DIST python-catcher-0.1.7.tar.gz 3699 SHA256 9f229680d9a456fd5ae6acf218c34055029b1a72c9b44f90f34711be1b245f78 SHA512 118bc19a7c7072cbf95d25810f95753aa894619c5a92b32f56e02a752e48c1b6ccbedab7d538184ec6dc30061826a7924fb0a4644e5afa26dedff9b9cd710353 WHIRLPOOL cf955b8361104986cd46a9fda89e2907ab909e560339a55383185dad331e7c0d1fc247d505564672f04edcb69e45553b54a7e90c8e6847fa7793e85bdc2fc22e
diff --git a/dev-python/python-catcher/metadata.xml b/dev-python/python-catcher/metadata.xml
new file mode 100644
index 000000000000..1f6ea1567991
--- /dev/null
+++ b/dev-python/python-catcher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-catcher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-catcher/python-catcher-0.1.7.ebuild b/dev-python/python-catcher/python-catcher-0.1.7.ebuild
new file mode 100644
index 000000000000..9c94609dd530
--- /dev/null
+++ b/dev-python/python-catcher/python-catcher-0.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Beautiful stack traces for Python"
+HOMEPAGE="https://pypi.python.org/pypi/python-catcher/ http://ajenti.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ cd catcher || die
+ "${PYTHON}" -m unittest || die
+}