summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-25 20:21:53 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-25 20:41:49 +0200
commit7249d7f1a2d67c4b9f749fddac1199a622e91387 (patch)
treee242a74512974fa2de7fe46da9ec738dbf7d89a6 /dev-python/python-cinderclient
parentdev-scheme/chibi: new package; add version 0.10 and live (diff)
downloadgentoo-7249d7f1a2d67c4b9f749fddac1199a622e91387.tar.gz
gentoo-7249d7f1a2d67c4b9f749fddac1199a622e91387.tar.bz2
gentoo-7249d7f1a2d67c4b9f749fddac1199a622e91387.zip
dev-python/python-cinderclient: add 8.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 384895f82596..200474203b0e 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,2 +1,3 @@
DIST python-cinderclient-8.0.0.tar.gz 236611 BLAKE2B 818279d06b597a00a66c34cf3b468e8293aaf1e90fd04c996e118ea206d475e598d7c8b9ca78542bd07ada1db5d7a2c7ea9a3748fe85ad787d283c8d8073ecc6 SHA512 ae0c5e1d6f0c173382f57f95ac05ec8872a8ed548b145c1f91d96ab7b9e4602cba11a7205c26c81027ca4ad07cbb69f675244e3606ae5dca00c22eeb8bedc126
DIST python-cinderclient-8.1.0.tar.gz 235387 BLAKE2B 04b6d9c847ee2f56ccde1e9c953b919282dc45a078b4444cc88d00633d2158ec175d042ef988b1b97781de0de643c7703178dd847a792a8f3f5509b9ff331e68 SHA512 414e7334f84e84edc9a8eb6588be780899c408ce2d744e24622004759e0127f4a73167f78a6ce432d2ed44a745b721cf5c42439f19adbea009451573df5fdf14
+DIST python-cinderclient-8.2.0.tar.gz 233148 BLAKE2B 4ada4562ff1e51a284cf98e7ca4b324a05a4524951d6193bb4683a3986bc8a26a48373ef78613f3b94ed475992fb781b409fe58f9f3655f3f721b38f7eab770b SHA512 86e7a0c18d960f00448e20485d91443d185902db281014c99f35af463843be6d4bca80712edf44189b53e25853af064c14de18e943d9fdee29446180d9b91bbc
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.2.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.2.0.ebuild
new file mode 100644
index 000000000000..a87d02779911
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}