summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-13 14:41:44 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-14 09:03:42 +0800
commitcd49980cb0a4ec17df427d5addf7090cb41ce976 (patch)
tree570f1dc2ee2ab1965f4c5b74fd327dc734e22528 /dev-python/python-ctags
parentwww-apps/klaus: reset order of maintainers in metadata.xml (diff)
downloadgentoo-cd49980cb0a4ec17df427d5addf7090cb41ce976.tar.gz
gentoo-cd49980cb0a4ec17df427d5addf7090cb41ce976.tar.bz2
gentoo-cd49980cb0a4ec17df427d5addf7090cb41ce976.zip
dev-python/python-ctags: new package
dependency of www-apps/klaus Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1255 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/python-ctags')
-rw-r--r--dev-python/python-ctags/Manifest1
-rw-r--r--dev-python/python-ctags/metadata.xml18
-rw-r--r--dev-python/python-ctags/python-ctags-1.0.6.ebuild20
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-ctags/Manifest b/dev-python/python-ctags/Manifest
new file mode 100644
index 000000000000..ec3804604266
--- /dev/null
+++ b/dev-python/python-ctags/Manifest
@@ -0,0 +1 @@
+DIST python-ctags-1.0.6.tar.gz 24275 SHA256 16a3fe367360167dc62fd2dc4a262659c6c1a7454aac95eb491edc44345ed565 SHA512 d26663fbb216843b6a3417bc28e89a1cb8666d7ed6aab3d05e87ac2be1edac111b7a3f3d487b42d33d25f4ed984c76933991c40a4c946ac7710b4a55c781563b WHIRLPOOL e369048183735302b81e2d33ffd183e2e8cfed7019741dfecacad7392de01295188c760f71a6125fa28e5f6370da8d11b0756de801e2484af6d7c6a4590731ce
diff --git a/dev-python/python-ctags/metadata.xml b/dev-python/python-ctags/metadata.xml
new file mode 100644
index 000000000000..06a584d77e4e
--- /dev/null
+++ b/dev-python/python-ctags/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">humanize</remote-id>
+ <remote-id type="github">hddmet/python-ctags</remote-id>
+ <bugs-to>https://github.com/hddmet/python-ctags/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ctags/python-ctags-1.0.6.ebuild b/dev-python/python-ctags/python-ctags-1.0.6.ebuild
new file mode 100644
index 000000000000..7bd06d347939
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.0.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/hddmet/python-ctags/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"