summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-09-04 13:55:42 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-09-04 14:03:02 -0700
commit0e8604f773c04990dc4eeb4455d85ee34847e3d7 (patch)
treedcb00a3febf08b621eabe64c1d8f34c89fa65e7e /dev-python/python-daemon
parentacct-user/nslcd: New package (diff)
downloadgentoo-0e8604f773c04990dc4eeb4455d85ee34847e3d7.tar.gz
gentoo-0e8604f773c04990dc4eeb4455d85ee34847e3d7.tar.bz2
gentoo-0e8604f773c04990dc4eeb4455d85ee34847e3d7.zip
dev-python/python-daemon-2.2.4: Bump, add new python impls
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest1
-rw-r--r--dev-python/python-daemon/python-daemon-2.2.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index 1dbada90ee38..902d8697a669 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1 +1,2 @@
DIST python-daemon-2.1.2.tar.gz 76176 BLAKE2B f8252bb3ee23b9d2a4ac33057df98720708b2a7e10c38c188c537d3c90ad641e33ba73e39f1bbfca10655e2ebd5d550179ed55d09a2f767832fa1d26accc9e21 SHA512 28ae118fd652a0a26524215568df0b16264e3a844640fe47f0a08c45c7a16be1b60d78293c2fc13edfe1402a8b5dcd72ec11101c3b53e5b66f232b7e21d5d346
+DIST python-daemon-2.2.4.tar.gz 80775 BLAKE2B 3f260993a2207e6467db03c456d9f8621d1f3252236b6d49432ff14c1039416db901feb5d405620106d02ae2ea186fd0b10183156f31d17f9f4fa62964fbd333 SHA512 9a7a4e23e126f05e4c1c503f15401cddd758c5f9195c370997060ca1bbfe71cc51d82d3ae16bcf0023c28fa50b0b8d6cd406e515b27725ffa9fec10fde3ed64a
diff --git a/dev-python/python-daemon/python-daemon-2.2.4.ebuild b/dev-python/python-daemon/python-daemon-2.2.4.ebuild
new file mode 100644
index 000000000000..c056689964c1
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py