summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-daemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-daemon')
-rw-r--r--dev-python/python-daemon/Manifest3
-rw-r--r--dev-python/python-daemon/metadata.xml8
-rw-r--r--dev-python/python-daemon/python-daemon-1.6-r1.ebuild28
-rw-r--r--dev-python/python-daemon/python-daemon-2.0.4.ebuild33
-rw-r--r--dev-python/python-daemon/python-daemon-2.0.5.ebuild34
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
new file mode 100644
index 000000000000..eea04a5f2922
--- /dev/null
+++ b/dev-python/python-daemon/Manifest
@@ -0,0 +1,3 @@
+DIST python-daemon-1.6.tar.gz 41564 SHA256 1665fb16bfeae72f16aa2de40bc75661458bd42731a7d463a911a8d5eaf96c0b SHA512 ff9480844d8f57a09f27067aaa78669c167f66b2cc05f9b3baa660bc0aa21228d4894eeaeb3440611c1e0f0d5633b1c60eac60893da4a86d1db4b94d99961299 WHIRLPOOL 35ec95c43b7822fa9abca9bb21442fe2b9f83b7171d8e8a87cc12a7e07a2653fbd5b4aea7adbba799c76d8b4cf3c844b665ae3b90d5b77afe4b33c88dce85ba4
+DIST python-daemon-2.0.4.tar.gz 71162 SHA256 07ca8c037d85bd365ef42ad7786d9d5866e636ede8e21da695a9ab4dc8c4dc19 SHA512 923680198616ffd17bc86f92c6639afe97a13d9a8d6658fb09011ddc57dabd0bcc4009abdd0be837ab092153f22ce535796705091d0785ce6845bf1919a419b3 WHIRLPOOL 2bdf2eeef58288f7df7f96fdb667b69d8b55f702bce376acc9a260a0e07f7541970834e9db3eb5effc9d37cb3df99a05979b4ac22bfb9ff72efa869fabfeb69e
+DIST python-daemon-2.0.5.tar.gz 71298 SHA256 afde4fa433d94d007206ee31a0941d55b5eb232a5422b670aad628547b46bf68 SHA512 6bac000e304e0828dd54cfa3c7972c07dedb07684f98e5f7e05815df2cf2f25c43ddf4f121e8d282519bdfcca0990fab585f18e43b2578123bc7fbe5f5f8b73e WHIRLPOOL db39b107f7c96cf5fd1c62262ed33bb6e53e8f79836be6d12dabd6b05ec59457df4fea70cd7fa2c38548fc0b60b22d01a62895251b6f26bfa0d9fe5577cdf55f
diff --git a/dev-python/python-daemon/metadata.xml b/dev-python/python-daemon/metadata.xml
new file mode 100644
index 000000000000..836e1cdf2ccc
--- /dev/null
+++ b/dev-python/python-daemon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">python-daemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-daemon/python-daemon-1.6-r1.ebuild b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
new file mode 100644
index 000000000000..3da32bc357c4
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-1.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="http://pypi.python.org/pypi/python-daemon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/minimock[${PYTHON_USEDEP}] )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-daemon/python-daemon-2.0.4.ebuild b/dev-python/python-daemon/python-daemon-2.0.4.ebuild
new file mode 100644
index 000000000000..edb1f2bda2da
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="http://pypi.python.org/pypi/python-daemon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/unittest2-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-daemon/python-daemon-2.0.5.ebuild b/dev-python/python-daemon/python-daemon-2.0.5.ebuild
new file mode 100644
index 000000000000..0efe356fc90a
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="http://pypi.python.org/pypi/python-daemon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/unittest2-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ esetup.py test
+}