summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-19 09:55:57 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-19 09:31:18 +0200
commite3d5caa093b27a2c7fb63b5f11df656829996134 (patch)
tree8f474f7ddbe210c51362465625f0c397931dcfe6 /dev-python/python-debian
parentdev-python/python-cstruct: bump to python 3.{9,10} (diff)
downloadgentoo-e3d5caa093b27a2c7fb63b5f11df656829996134.tar.gz
gentoo-e3d5caa093b27a2c7fb63b5f11df656829996134.tar.bz2
gentoo-e3d5caa093b27a2c7fb63b5f11df656829996134.zip
dev-python/python-debian: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/python-debian-0.1.39.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.39.ebuild b/dev-python/python-debian/python-debian-0.1.39.ebuild
index 372a80438504..63a9d4c02307 100644
--- a/dev-python/python-debian/python-debian-0.1.39.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.39.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -13,19 +13,18 @@ SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? ( app-arch/dpkg )
"
+distutils_enable_tests unittest
+
PATCHES=( "${FILESDIR}/0.1.39-disable-apt-pkg.patch" )
python_compile_all() {
@@ -33,5 +32,5 @@ python_compile_all() {
}
python_test() {
- ${EPYTHON} -m unittest discover --verbose lib || die "Testing failed with ${EPYTHON}"
+ eunittest lib
}