summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-15 12:40:33 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-15 12:41:21 -0500
commit4d2997add72b9853e0da52efe8a7ca78ef10e8c4 (patch)
treef74a1499b88d77aaccfcdd5130b14ec95369fc8c /dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
parentapp-misc/elasticsearch: add missing die (diff)
downloadgentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.tar.gz
gentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.tar.bz2
gentoo-4d2997add72b9853e0da52efe8a7ca78ef10e8c4.zip
dev-python/python-djvulibre: bump to 0.8
Bug: https://bugs.gentoo.org/601518 Package-Manager: Portage-2.3.3_p32, Repoman-2.3.1_p25
Diffstat (limited to 'dev-python/python-djvulibre/python-djvulibre-0.8.ebuild')
-rw-r--r--dev-python/python-djvulibre/python-djvulibre-0.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
new file mode 100644
index 000000000000..366d9f73f01a
--- /dev/null
+++ b/dev-python/python-djvulibre/python-djvulibre-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of Python bindings for the DjVuLibre library"
+HOMEPAGE="http://jwilk.net/software/python-djvulibre"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/djvu"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ ln -s "${S}/tests" "${BUILD_DIR}/tests" || die
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die
+}