summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-22 08:47:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-22 10:01:54 +0100
commitdd4481af698dac6d4a533d94f77e90a417b489f0 (patch)
tree3cea297cf2a470afe3ae18608d374f084f3f94a1 /dev-python/python-email-validator
parentdev-python/flatbuffers: Bump to 23.1.21 (diff)
downloadgentoo-dd4481af698dac6d4a533d94f77e90a417b489f0.tar.gz
gentoo-dd4481af698dac6d4a533d94f77e90a417b489f0.tar.bz2
gentoo-dd4481af698dac6d4a533d94f77e90a417b489f0.zip
dev-python/python-email-validator: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-email-validator')
-rw-r--r--dev-python/python-email-validator/Manifest1
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.3.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-email-validator/Manifest b/dev-python/python-email-validator/Manifest
index cdfa6655d652..f3ba77c4f600 100644
--- a/dev-python/python-email-validator/Manifest
+++ b/dev-python/python-email-validator/Manifest
@@ -1 +1,2 @@
DIST python-email-validator-1.3.0.gh.tar.gz 28555 BLAKE2B 7b13b4093be2b97260d01c562a205d299570e63bfba2f8e411000bc19319e9b538e95f2f4d33962b03fe5dc47c3690b8a0134b792f6822386ab6b20b260a991e SHA512 b10139f8eb221fa15a12c44f2c87d17449e317c6edfd4c6a99dc122a9178dcc4c3ef20f99f0feefb6a5b4a9460169b22d835871d2be88efd59f1474ff3d9aa06
+DIST python-email-validator-1.3.1.gh.tar.gz 28691 BLAKE2B eb69028066e969a935117f51a32d75595468797a82608bcb7f6ebcbebada01aac29e3e223efc849dc519d85897a375cdc584760f3cb5a431e2c39aa566c20514 SHA512 7806ef35c07cf0cfef3d8c6c7fe6dd3cb58da091a134b57d879a2cfcdf6425f8729ab8b03194135749ae47b369da47434c1d130432cfaa8eeaf5d07149c15dc2
diff --git a/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild b/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild
new file mode 100644
index 000000000000..cdde06720d0a
--- /dev/null
+++ b/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A robust email syntax and deliverability validation library"
+HOMEPAGE="
+ https://github.com/JoshData/python-email-validator/
+ https://pypi.org/project/email-validator/
+"
+SRC_URI="
+ https://github.com/JoshData/python-email-validator/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # these tests rely on access to gmail.com
+ tests/test_main.py::test_deliverability_found
+ tests/test_main.py::test_deliverability_fails
+ # these tests rely on example.com being resolvable
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@example.com]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example.com]"
+ tests/test_main.py::test_validate_email__with_caching_resolver
+ tests/test_main.py::test_main_single_good_input
+ tests/test_main.py::test_main_multi_input
+ tests/test_main.py::test_main_input_shim
+)