summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-08-06 22:55:09 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2016-08-06 22:55:09 +0200
commit6009c41728f7afe3072ebfe70b0fac4e43d22a96 (patch)
tree5565c5b049d1622a9c942637e79f23508c484e8e /dev-python/python-ethtool/python-ethtool-0.11.ebuild
parentapp-eselect/eselect-lua: add myself as maintainer (diff)
downloadgentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.tar.gz
gentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.tar.bz2
gentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.zip
Initial import
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-ethtool/python-ethtool-0.11.ebuild')
-rw-r--r--dev-python/python-ethtool/python-ethtool-0.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-ethtool/python-ethtool-0.11.ebuild b/dev-python/python-ethtool/python-ethtool-0.11.ebuild
new file mode 100644
index 000000000000..810f7fb80220
--- /dev/null
+++ b/dev-python/python-ethtool/python-ethtool-0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+# TODO: install scripts and their man pages
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Ethernet settings python bindings"
+HOMEPAGE="https://fedorahosted.org/python-ethtool/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libnl:3"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_include-net-if.h-for-IFF_-macros.patch"
+ distutils-r1_src_prepare
+}