summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-25 23:56:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 00:16:33 +0100
commit841ff6e4a6752df2437776b8b963c4e92eceff1f (patch)
tree3bba914650635d55dfac4687e7e48aaa7b08dbb4 /dev-python/python-ironicclient
parentdev-python/ipython: Bump to 8.1.0 (diff)
downloadgentoo-841ff6e4a6752df2437776b8b963c4e92eceff1f.tar.gz
gentoo-841ff6e4a6752df2437776b8b963c4e92eceff1f.tar.bz2
gentoo-841ff6e4a6752df2437776b8b963c4e92eceff1f.zip
dev-python/python-ironicclient: Bump to 4.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-ironicclient')
-rw-r--r--dev-python/python-ironicclient/Manifest1
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-4.11.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/Manifest b/dev-python/python-ironicclient/Manifest
index a062b136a77b..0cce7f8bcfe5 100644
--- a/dev-python/python-ironicclient/Manifest
+++ b/dev-python/python-ironicclient/Manifest
@@ -1 +1,2 @@
DIST python-ironicclient-4.10.0.tar.gz 219314 BLAKE2B 3c4c7d26ac06fa6f79fcc144b3bc5adf2956ccb5685c65da3a01b314f69626df72963b21e32c2208d7de8e0741acf0fce0bf9886b0e623454cd44e5e7b4eb314 SHA512 451ecd31f02c20e237353a2b5d8a5878fdc09dea0ed5d0f12c31f1e4f9d80324cb18b6838199be91a565cf21479a4fbd4dc67cb94b4e8b09847393c8d3581448
+DIST python-ironicclient-4.11.0.tar.gz 220770 BLAKE2B a653cf04497a4df9627ed5026094690d0569dd7d6c55abf3a3223fee8cbc14e450106645ed1e4461cb3931f2ca49c8df47ca9e8e2ec9478cf15fcc0623d19379 SHA512 863429269807f759a864e427206d29a68b7431ce33009e1b6d3a630ab154e66b85b9f61dd90303a681a5ed459005af1686edf056eb9a63cfb6de1f1eda85bbb5
diff --git a/dev-python/python-ironicclient/python-ironicclient-4.11.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-4.11.0.ebuild
new file mode 100644
index 000000000000..39d952acbce6
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-4.11.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest