summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-30 16:43:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-30 20:57:25 +0300
commitba7e6068782862918e1f3bf7e2d55ef231f09ffa (patch)
treecc27223e2be6c75cbe01e7521106448967fe81d1 /dev-python/python-ironicclient
parentdev-python/python-openstackclient: add 5.6.0, enable tests, enable py3.9 (diff)
downloadgentoo-ba7e6068782862918e1f3bf7e2d55ef231f09ffa.tar.gz
gentoo-ba7e6068782862918e1f3bf7e2d55ef231f09ffa.tar.bz2
gentoo-ba7e6068782862918e1f3bf7e2d55ef231f09ffa.zip
dev-python/python-ironicclient: add 4.8.0, enable tests, py3.9
Closes: https://bugs.gentoo.org/798393 Closes: https://bugs.gentoo.org/812911 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-ironicclient')
-rw-r--r--dev-python/python-ironicclient/Manifest1
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-4.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/Manifest b/dev-python/python-ironicclient/Manifest
index 6144bff24e94..93c90175743f 100644
--- a/dev-python/python-ironicclient/Manifest
+++ b/dev-python/python-ironicclient/Manifest
@@ -1 +1,2 @@
DIST python-ironicclient-4.4.0.tar.gz 205165 BLAKE2B eac0eea383890d9d9d70594300df5d8771217e0ba226a38da38544e715487c12d3fcace07651b84e180ee0601ae6bb3c17b6ed47130bd009ed351f1e4d270d64 SHA512 8d9325e464804503a504bbcc3211f0e6f50d4a1cccf652960d1020e1cd0141f8ac67ebcbab37ba7af417679fef3f25d5aa48b9e8134fffbc971cff34446fec3c
+DIST python-ironicclient-4.8.0.tar.gz 217915 BLAKE2B 6ef8636a063eaa344bd414aa5a75b08dc4ba4c615835defba522233127baa2454f9c54de40874cd5fde9de1748887ad0c1a002da31176059a5d8562a8ffeda87 SHA512 c784124e59ee836c3349e17f347b59bb96e28afd067b7de2d948563293c16d2f641c15d3312c56c9fed476e1c8c9de65949bfdc139cd9267cb210c5cc70ccbb3
diff --git a/dev-python/python-ironicclient/python-ironicclient-4.8.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-4.8.0.ebuild
new file mode 100644
index 000000000000..fe7665bdc9ab
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-4.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest