summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-02-21 14:53:56 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-02-21 14:53:56 -0600
commit5e70799a358f52b9ffd23fe68ef9f167ddc33277 (patch)
tree5597d411807301f5a68e24b6a8a0da4fdcfa9728 /dev-python/python-jwt/python-jwt-1.2.0.ebuild
parentnet-misc/youtube-dl: Bump to 2021.02.22 (diff)
downloadgentoo-5e70799a358f52b9ffd23fe68ef9f167ddc33277.tar.gz
gentoo-5e70799a358f52b9ffd23fe68ef9f167ddc33277.tar.bz2
gentoo-5e70799a358f52b9ffd23fe68ef9f167ddc33277.zip
dev-python/python-jwt: JSON Web Token library for python 3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/python-jwt/python-jwt-1.2.0.ebuild')
-rw-r--r--dev-python/python-jwt/python-jwt-1.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-jwt/python-jwt-1.2.0.ebuild b/dev-python/python-jwt/python-jwt-1.2.0.ebuild
new file mode 100644
index 000000000000..0a3aabc02d75
--- /dev/null
+++ b/dev-python/python-jwt/python-jwt-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="JSON Web Token library for python 3"
+HOMEPAGE="https://github.com/GehirnInc/python-jwt"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hvac/hvac.git"
+else
+ SRC_URI="https://github.com/GehirnInc/python-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e 's/^addopts =.*/addopts = jwt/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}