summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-26 21:20:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-26 21:20:56 -0500
commitd51848cd7d8143cf7cf25b696846c363907d5e3e (patch)
tree40f96800c4fa7eede9aa7dda4542ba027b3b4f20 /dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild
parentdev-python/python-neutronclient: bup for mitaka (diff)
downloadgentoo-d51848cd7d8143cf7cf25b696846c363907d5e3e.tar.gz
gentoo-d51848cd7d8143cf7cf25b696846c363907d5e3e.tar.bz2
gentoo-d51848cd7d8143cf7cf25b696846c363907d5e3e.zip
dev-python/python-keystoneclient: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild')
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild
new file mode 100644
index 000000000000..92aae528b5e8
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-2.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client Library for OpenStack Identity"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Note: blacklist version not in portage:
+#doc? ( !~dev-python/sphinx-1.3_preb1[${PYTHON_USEDEP}] )
+
+CDEPEND="
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+TCDEPEND="
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-lib-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/bandit-0.13.2[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+"
+PATCHES=(
+)
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+ sed -i '/^argparse/d' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}