summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-14 21:05:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-14 21:21:01 -0500
commit7e723a4f27ce8f9296f16c783d39dcf139fba6a8 (patch)
treeab676b4c3eb6b7e57b95953768a9ac9aa2bb8416 /dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild
parentdev-python/oslo-log: 3.44.1 bump (diff)
downloadgentoo-7e723a4f27ce8f9296f16c783d39dcf139fba6a8.tar.gz
gentoo-7e723a4f27ce8f9296f16c783d39dcf139fba6a8.tar.bz2
gentoo-7e723a4f27ce8f9296f16c783d39dcf139fba6a8.zip
dev-python/python-keystoneclient: 3.21.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild')
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild
new file mode 100644
index 000000000000..ba975e3c0cf3
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-3.21.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client Library for OpenStack Identity"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+#PATCHES=(
+#)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}