summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-04 10:41:53 +0100
committerMatt Turner <mattst88@gentoo.org>2020-11-04 20:38:20 -0500
commit65d11459c8d97daf169dfa17150886f36f8197b3 (patch)
tree69985284a2fadbb4da4c61ac3464c0d753934cab /dev-python/python-language-server
parentdev-python/pytest-regressions: version bump 2.0.2 (diff)
downloadgentoo-65d11459c8d97daf169dfa17150886f36f8197b3.tar.gz
gentoo-65d11459c8d97daf169dfa17150886f36f8197b3.tar.bz2
gentoo-65d11459c8d97daf169dfa17150886f36f8197b3.zip
dev-python/python-language-server: version bump 0.36.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/python-language-server')
-rw-r--r--dev-python/python-language-server/Manifest1
-rw-r--r--dev-python/python-language-server/python-language-server-0.36.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/python-language-server/Manifest b/dev-python/python-language-server/Manifest
index b0c0516bc628..baace4dcfdfc 100644
--- a/dev-python/python-language-server/Manifest
+++ b/dev-python/python-language-server/Manifest
@@ -1,2 +1,3 @@
DIST python-language-server-0.34.1.tar.gz 70238 BLAKE2B 55ec41875907bb6c09f682c8ce6165e7e2fab5d03c3d4758bcbe658968aeeee7f0316a472efe68ddd87872b0e2d34908c8a7e9528aa5eec6d3359b2565a2cbbc SHA512 12404753f4271ec3606cee535ba8e886037bf0c61cc5c4415358066be837e2248f6393124340551387cba7351dee924b4f5ebc9c4e35b1ab0943067968967a90
DIST python-language-server-0.35.1.tar.gz 72944 BLAKE2B fe469e5365dec4a2192a2ca2f75fc9f05476434c0f6db26d851521149053455b256678ed98c5f1209d30b262808b615a3f7ac77fb604adf1455203e40f93c96f SHA512 278f281c8c82729ad60db2785b3f4b64568de529edb7a6f1b5683d09838ea43ed79182c50e42210e766b9a3f3c10b0c0256121b9925803c45f9e948f144ca994
+DIST python-language-server-0.36.0.tar.gz 74398 BLAKE2B 7a112f22df88bc06eba8c480e9927ce87278e24bf2e8de8c6be407569c195f96e15a5196f70c2840c8619dc512813fff8224df9547c258f045b98c652f5cc686 SHA512 4589812b4e05b9db5d9308ec97c6a701ea0cfdc62d2fe117c7581ee22ccf7ed84377556785500be3a5351277d4e70651d597bd18d629c39821c79b79660fbc83
diff --git a/dev-python/python-language-server/python-language-server-0.36.0.ebuild b/dev-python/python-language-server/python-language-server-0.36.0.ebuild
new file mode 100644
index 000000000000..532e9b34cd45
--- /dev/null
+++ b/dev-python/python-language-server/python-language-server-0.36.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="An implementation of the Language Server Protocol for Python"
+HOMEPAGE="https://github.com/palantir/python-language-server"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-3.8.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+)"
+
+RDEPEND="
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ >=dev-python/python-jsonrpc-server-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ujson-3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '0,/addopts/I!d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "Automatically formats Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}