summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-01-13 18:23:17 +0800
committerYixun Lan <dlan@gentoo.org>2021-01-14 07:01:38 +0800
commitece0688d7e87c228aae050c734caabc71310201b (patch)
tree556b5719ddbeccc4fc0958e9fffe5e586b29365a /dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild
parentdev-lang/go: Stabilize 1.15.6-r1 ppc64, #764509 (diff)
downloadgentoo-ece0688d7e87c228aae050c734caabc71310201b.tar.gz
gentoo-ece0688d7e87c228aae050c734caabc71310201b.tar.bz2
gentoo-ece0688d7e87c228aae050c734caabc71310201b.zip
dev-python/python-linux-procfs: version bump 0.6.3
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild')
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild
new file mode 100644
index 000000000000..06ab368f999e
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.6.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
+ https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"