summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-11 08:56:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-11 09:41:19 +0200
commitf4ed4767a850f5cf49d573935c9bc77d24bf8401 (patch)
treefedbc3ade551ed9f7ae78e2207920e4e6949548d /dev-python/python-lsp-server
parentdev-libs/libgit2: Use libpcre2 (diff)
downloadgentoo-f4ed4767a850f5cf49d573935c9bc77d24bf8401.tar.gz
gentoo-f4ed4767a850f5cf49d573935c9bc77d24bf8401.tar.bz2
gentoo-f4ed4767a850f5cf49d573935c9bc77d24bf8401.zip
dev-python/python-lsp-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.3.3.ebuild91
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.4.0.ebuild90
3 files changed, 0 insertions, 183 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 105ff77f9f34..f1d239e48ddf 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,3 +1 @@
-DIST python-lsp-server-1.3.3.tar.gz 62604 BLAKE2B 16f49013ccefc0dabcf58c6007c05828a930d0bc873805543fde79630bdc8bd020cb63d0d0ba56c181282a96c57c6084acde30dc2a8011d208040c2a93c3644b SHA512 94e9bf1e74799c395589451c02c1220bc79336e1c1cdc243e95e891f61c7977b2438d78da3db3da572022870e67305b8caca22241e0cfab23d3b546639c69aa7
-DIST python-lsp-server-1.4.0.tar.gz 75443 BLAKE2B 7522ff0d5c9a0c9300f288debc4f606168f968cad80e32d612a674803046c91dc777d9ee320cf844224f6da791b6d66413c643fc48799ef5f57c19bca4f09858 SHA512 9f53e288b9bdb22575b06ec8a89022f533a323457746ef8e2cb52c84f06ac48b3408b4ebfbf96754ce68cdc9ddf1a745365d5ea21ba188a4372064fc87c1e6f4
DIST python-lsp-server-1.4.1.tar.gz 76416 BLAKE2B 65638b876182c478434c563371b802367fb8439820ccf57e4404dc1507f3cd514ae5d738d418386607db606025fe5126a533c656ec3fede53fdcfd364a4292cf SHA512 4c9171adc88d219c80055ebbc76566583925129969467c156277b52de9b5981b74b11b9961247045ea98cd9e51e146b2d606c8351a7be5db76f6f4e0e4d7195c
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.3.3.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.3.3.ebuild
deleted file mode 100644
index cd8b13b06497..000000000000
--- a/dev-python/python-lsp-server/python-lsp-server-1.3.3.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python Language Server for the Language Server Protocol"
-HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-IUSE="all-plugins"
-
-BDEPEND="
- test? (
- >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
- <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
- <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
- >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="
- >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
- <dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
- >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
- dev-python/pluggy[${PYTHON_USEDEP}]
- all-plugins? (
- >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
- <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
- <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pytest-cov dep
- sed -i -e '0,/addopts/I!d' setup.cfg || die
-
- # This fails with py3.10, but it is not important. Instead of
- # 'invalid syntax' we now get 'syntax-error'
- sed -i -e 's/test_syntax_error_pylint_py3/_&/' \
- test/plugins/test_pylint_lint.py || die
-
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- optfeature "Automatically formats Python code to conform to the PEP 8 style guide" dev-python/autopep8
- optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
- optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
- optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
- optfeature "Python docstring style checker" dev-python/pydocstyle
- optfeature "Passive checker for Python programs" dev-python/pyflakes
- optfeature "Python code static checker" dev-python/pylint
- optfeature "Python refactoring library" dev-python/rope
- optfeature "A formatter for Python files" dev-python/yapf
-}
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.4.0.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.4.0.ebuild
deleted file mode 100644
index ad82e4fc954d..000000000000
--- a/dev-python/python-lsp-server/python-lsp-server-1.4.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python Language Server for the Language Server Protocol"
-HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-IUSE="all-plugins"
-
-BDEPEND="
- test? (
- >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
- <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
- <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
- >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="
- >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
- <dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
- >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
- dev-python/pluggy[${PYTHON_USEDEP}]
- all-plugins? (
- >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
- <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
- <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pytest-cov dep
- sed -i -e '0,/addopts/I!d' setup.cfg || die
-
- # This fails with py3.10, but it is not important. Instead of
- # 'invalid syntax' we now get 'syntax-error'
- sed -i -e 's/test_syntax_error_pylint_py3/_&/' \
- test/plugins/test_pylint_lint.py || die
-
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
- optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
- optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
- optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
- optfeature "Python docstring style checker" dev-python/pydocstyle
- optfeature "Passive checker for Python programs" dev-python/pyflakes
- optfeature "Python code static checker" dev-python/pylint
- optfeature "Python refactoring library" dev-python/rope
- optfeature "A formatter for Python files" dev-python/yapf
-}