summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 07:05:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 07:07:18 +0200
commitc6db7a0a2470327026a2a4b79251f51d4fc6fdd0 (patch)
tree85878e9942a3180fbe7ba0808d7eb626182c324d /dev-python/python-lzo
parentdev-python/hatch-fancy-pypi-readme: Bump to 23.1.0 (diff)
downloadgentoo-c6db7a0a2470327026a2a4b79251f51d4fc6fdd0.tar.gz
gentoo-c6db7a0a2470327026a2a4b79251f51d4fc6fdd0.tar.bz2
gentoo-c6db7a0a2470327026a2a4b79251f51d4fc6fdd0.zip
dev-python/python-lzo: Bump to 1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lzo')
-rw-r--r--dev-python/python-lzo/Manifest1
-rw-r--r--dev-python/python-lzo/python-lzo-1.15.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-lzo/Manifest b/dev-python/python-lzo/Manifest
index 68338d30a0d2..f014db482b3f 100644
--- a/dev-python/python-lzo/Manifest
+++ b/dev-python/python-lzo/Manifest
@@ -1 +1,2 @@
DIST python-lzo-1.14.tar.gz 14050 BLAKE2B e1df6b842562064ca13ddbacb194047ca343694d480a5a65e7d2876ec98a4215b4badb3b2a839f308dea8624c162a0536f363c093bcb2e5b48c68b69fb472729 SHA512 036cf7199afe12cec8b9c7ee92134f58357e1f892870ade3a619541a69c9cc92155892d53bd43330732b848016c2997e096a9a492e52f15d04fa516ca7645b93
+DIST python-lzo-1.15.tar.gz 17633 BLAKE2B 577c78feeced5fba833c27b212b621a4cd8c9d4fe2dfb44d93cfd2b0aa9e88ee66926ec47d129b75496936f55d65e99e816d00e110b1d70300639a3907d823fd SHA512 1c7889f01b4809e7023804b702ac35a59e45df735865ff50449c69b414966c9f928c254ef7dde9e28fcc44ba4ac12df220bd6a6d34c0d274123f59c65ce3c5fe
diff --git a/dev-python/python-lzo/python-lzo-1.15.ebuild b/dev-python/python-lzo/python-lzo-1.15.ebuild
new file mode 100644
index 000000000000..349a30e0e5b0
--- /dev/null
+++ b/dev-python/python-lzo/python-lzo-1.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 prefix pypi
+
+DESCRIPTION="Python interface to lzo"
+HOMEPAGE="
+ https://github.com/jd-boyd/python-lzo/
+ https://pypi.org/project/python-lzo/
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/lzo:2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ hprefixify setup.py
+ distutils-r1_python_prepare_all
+}